I'm looking for a part-time remote job.

Hire me


I'm the author of:

Mastering Redmine is a comprehensive guide with tips, tricks and best practices, and an easy-to-learn structure.

Check the book's project or

Buy the book

Social pages of the book:

By buying this book you also donate to Redmine (see this page).


Follow me:

Bug #2360

Redmine 3 compatibility

Added by Lukas Pirl about 5 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
24 Feb 2015
Due date:
% Done:

100%

Redmine version:
External issue:

Description

bin/bundle exec rake db:migrate RAILS_ENV=production dies with

rake aborted!
uninitialized constant ActiveRecord::Observer
/opt/redmine-3.0.0/plugins/redmine_scm/app/models/repository_observer.rb:1:in `<top (required)>'
/opt/redmine-3.0.0/plugins/redmine_scm/init.rb:19:in `<top (required)>'
/opt/redmine-3.0.0/lib/redmine/plugin.rb:155:in `block in load'
/opt/redmine-3.0.0/lib/redmine/plugin.rb:146:in `each'
/opt/redmine-3.0.0/lib/redmine/plugin.rb:146:in `load'
/opt/redmine-3.0.0/config/initializers/30-redmine.rb:21:in `<top (required)>'
/var/lib/gems/1.9.1/gems/railties-4.2.0/lib/rails/engine.rb:652:in `block in load_config_initializer'
/var/lib/gems/1.9.1/gems/activesupport-4.2.0/lib/active_support/notifications.rb:166:in `instrument'
/var/lib/gems/1.9.1/gems/railties-4.2.0/lib/rails/engine.rb:651:in `load_config_initializer'
/var/lib/gems/1.9.1/gems/railties-4.2.0/lib/rails/engine.rb:616:in `block (2 levels) in <class:Engine>'
/var/lib/gems/1.9.1/gems/railties-4.2.0/lib/rails/engine.rb:615:in `each'
/var/lib/gems/1.9.1/gems/railties-4.2.0/lib/rails/engine.rb:615:in `block in <class:Engine>'
/var/lib/gems/1.9.1/gems/railties-4.2.0/lib/rails/initializable.rb:30:in `instance_exec'
/var/lib/gems/1.9.1/gems/railties-4.2.0/lib/rails/initializable.rb:30:in `run'
/var/lib/gems/1.9.1/gems/railties-4.2.0/lib/rails/initializable.rb:55:in `block in run_initializers'
/var/lib/gems/1.9.1/gems/railties-4.2.0/lib/rails/initializable.rb:44:in `each'
/var/lib/gems/1.9.1/gems/railties-4.2.0/lib/rails/initializable.rb:44:in `tsort_each_child'
/var/lib/gems/1.9.1/gems/railties-4.2.0/lib/rails/initializable.rb:54:in `run_initializers'
/var/lib/gems/1.9.1/gems/railties-4.2.0/lib/rails/application.rb:352:in `initialize!'
/opt/redmine-3.0.0/config/environment.rb:14:in `<top (required)>'
/var/lib/gems/1.9.1/gems/railties-4.2.0/lib/rails/application.rb:328:in `require_environment!'
/var/lib/gems/1.9.1/gems/railties-4.2.0/lib/rails/application.rb:443:in `block in run_tasks_blocks'
Tasks: TOP => db:migrate => environment
(See full trace by running task with --trace)

Associated revisions

Revision 141 (diff)
Added by Andriy Lesyuk about 5 years ago

Fixes for Redmine 3.x: regexp fix and observer removal

History

#1 Updated by Adrian Antonana almost 5 years ago

Same problem here with ruby2.2.0 installed with rvm and redmine3.0.0

#2 Updated by Lukas Pirl almost 5 years ago

Is there any plan when to make the SCM-Creator plugin compatible with Redmine 3? Thanks!

#3 Updated by Damien R over 4 years ago

I also tried to install the plugin on Redmine 3 with no success. Errors given by the installer are obscure to me. Is-it planned to adapt the plugin to futures versions of Redmine ?

#4 Updated by Lukas Pirl over 4 years ago

Can you please post those errors if they are different from those in the issue’s description?

#5 Updated by Lukas Pirl over 4 years ago

It is caused by a missing gem.

Please add a Gemfile requiring rails-observers.

For those who have the issues described above, create the file Gemfile in the plugin’s root directory, add the line gem 'rails-observers' and continue the upgrade procedure from bundle install … on.

#6 Updated by Andriy Lesyuk over 3 years ago

  • Status changed from New to Open
  • Assignee set to Andriy Lesyuk
  • Target version set to 0.5.1

#7 Updated by Andriy Lesyuk about 3 years ago

  • Subject changed from redmine 3 compatibility to Redmine 3 compatibility
  • Status changed from Open to Closed
  • % Done changed from 0 to 100

The observer was removed in r141, as observers are no longer supported by Rails 4 (and Redmine 3).

Also available in: Atom PDF

Terms of use | Privacy policy