I'm looking for a part-time remote job.

Hire me


I'm the author of:

Mastering Redmine is a comprehensive guide with tips, tricks and best practices, and an easy-to-learn structure.

Check the book's project or

Buy the book

Social pages of the book:

By buying this book you also donate to Redmine (see this page).


Follow me:

Bug #2015

Grouping by custom field not working

Added by Vitaly Klimov over 7 years ago. Updated over 7 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
21 Mar 2012
Due date:
08 Jul 2012
% Done:

100%

Redmine version:
1.3.1
External issue:

Description

With the plugin installed grouping by custom field became broken. Screenshot attached:

grouping_error.jpg View (63 KB) Vitaly Klimov, 21 Mar 2012 15:16


Related issues

Related to Extended Fields - Bug #2138: Issues count is not shown Closed 15 Jan 2013 26 Jan 2013

Associated revisions

Revision 46 (diff)
Added by Andriy Lesyuk over 7 years ago

Overrode fetch_row_values for extended fields (fixes #2023), added == for CustomValue and _list.html.erb (fixes #2015), added Turkish translation (thanks Ismail Sezen)

History

#1 Updated by Andriy Lesyuk over 7 years ago

  • Status changed from New to Open

Thanks for reporting!

#2 Updated by Vitaly Klimov over 7 years ago

Actually it seems that this bug is caused by Redmine core - when splitting issues by group (file issues\_list.html.erb) Redmine does not convert group names to string thus comparing two CustomValue objects in our case. So there are two solutions:

  • one is to correct this in _list.html.erb
  • second is convert returned value to string explicitely in extended_query_custom_field_column.rb - although i do not know if it would cause problems in logic

#3 Updated by Andriy Lesyuk over 7 years ago

  • Target version set to 0.2.0b

#4 Updated by Andriy Lesyuk over 7 years ago

  • Due date set to 08 Jul 2012
  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Also available in: Atom PDF

Terms of use | Privacy policy