I'm looking for a part-time remote job.

Hire me


I'm the author of:

Mastering Redmine is a comprehensive guide with tips, tricks and best practices, and an easy-to-learn structure.

Check the book's project or

Buy the book

Social pages of the book:

By buying this book you also donate to Redmine (see this page).


Follow me:

Bug #2203

SVN repository page broke

Added by Yukinari Toyota over 8 years ago. Updated over 8 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Target version:
Start date:
30 Jul 2013
Due date:
14 Sep 2013
% Done:

100%

Redmine version:
2.2.3
External issue:

Description

Hi, I’m using scm-creator with redmine 2.2.3.stable.
And I’ve updated the plugin to recent Revision r127, then, svn repository page broke.
Please look at the attached screenshot for what’s happen.

Maybe, it’s caused by html_safe rule changes of string.gsub in rails 3.x (see https://github.com/rails/rails/commit/53a2c0baf2b128dd4808eca313256f6f4bb8c4cd)

I attached a simple patch to fix this, checked with redmine 2.2.3.
I hope this will be helpful.

broken_repositories_settings_page.png View (31.6 KB) Yukinari Toyota, 30 Jul 2013 15:56

svn_repository_borken_redmine2.2.patch View (716 Bytes) Yukinari Toyota, 30 Jul 2013 15:56

Associated revisions

Revision 129 (diff)
Added by Andriy Lesyuk over 8 years ago

Added patch file and fix for #2203

History

#1 Updated by Andriy Lesyuk over 8 years ago

  • Status changed from New to Open
  • Assignee set to Andriy Lesyuk
  • Target version set to 0.4.3

#2 Updated by Andriy Lesyuk over 8 years ago

  • Due date set to 14 Sep 2013
  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Added html_safe in a different place... Thanks!

Also available in: Atom PDF

Terms of use | Privacy policy