I'm looking for a part-time remote job.

Hire me


I'm the author of:

Mastering Redmine is a comprehensive guide with tips, tricks and best practices, and an easy-to-learn structure.

Check the book's project or

Buy the book

Social pages of the book:

By buying this book you also donate to Redmine (see this page).


Follow me:

Bug #2147

When sending an email redmine replies with 404

Added by Romain Schmitz about 7 years ago. Updated almost 7 years ago.

Status:
Won't Fix
Priority:
Normal
Assignee:
Target version:
-
Start date:
04 Feb 2013
Due date:
% Done:

0%

Redmine version:
External issue:

Description

The plugin worked when setting up the contact form and it shows up correctly in the frontend but when sending the actual email redmine replies

Page not found
The page you were trying to access doesn't exist or has been removed.

The request looks good:

POST /contact/mail HTTP/1.1
Host: example.com
User-Agent: Mozilla/5.0 (X11; Linux x86_64; rv:18.0) Gecko/20100101 Firefox/18.0
Accept: text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
Accept-Language: en-US,en;q=0.5
Accept-Encoding: gzip, deflate
Referer: http://example.com/contact/mail
Cookie: _redmine_session=BAh7D....
Connection: keep-alive

Something wrong with your controller?

History

#1 Updated by Romain Schmitz about 7 years ago

I forgot to tell you what environment I use:

Redmine version: 2.1.6.stable.11195
Ruby version: 1.8.7 (x86_64-linux)
Rails version: 3.2.11

#2 Updated by Andriy Lesyuk about 7 years ago

  • Status changed from New to Incomplete

Hi! Thanks for reporting!

You are using the plugin from SVN, right?

#3 Updated by Romain Schmitz almost 7 years ago

Sorry for replying so late. Yes, it’s the svn version.

I’ve just fetched the update and migrated the plugins with the same result as before.

Maybe I did something wrong?

git svn fetch
rake redmine:plugins:migrate RAILS_ENV=production

#4 Updated by Romain Schmitz almost 7 years ago

For some reason git svn fetch didn’t really get the latest update. I’ve now checked the plugin out with subversion, migrated the plugins and finally restarted redmine. Same issue.

#5 Updated by Andriy Lesyuk almost 7 years ago

Could you please check Redmine logs?

Anyway, it seems, the issue is in mailer templates, see this forum topic.

Please try copying files from plugin’s app/views/layouts and app/views/mailer into Redmine’s layouts and mailer directories correspondingly.

#6 Updated by Romain Schmitz almost 7 years ago

Sorry the logs have gone for that particular stacktrace but I’ve got some positive news anyway.

I think the reason was the route I have set to

root :to => 'contact_form#index', :as => 'home'

in config/routes.rb. When I changed this setting back to the default value your plugin worked like a charm aftwards. Then I changed it back and your plugin continued to work.

If that’s not the reason then I have no explanation for the issue. To be honest I don’t know much about redmine’s internals so I can’t investigate further.

#7 Updated by Andriy Lesyuk almost 7 years ago

So the issue went away?

#8 Updated by Romain Schmitz almost 7 years ago

Yes. The issue went away for a not quite known reason. This issue can be closed

#9 Updated by Andriy Lesyuk almost 7 years ago

  • Status changed from Incomplete to Won't Fix
  • Assignee set to Andriy Lesyuk

Thanks

Also available in: Atom PDF

Terms of use | Privacy policy