I'm looking for a part-time remote job.

Hire me


I'm the author of:

Mastering Redmine is a comprehensive guide with tips, tricks and best practices, and an easy-to-learn structure.

Check the book's project or

Buy the book

Social pages of the book:

By buying this book you also donate to Redmine (see this page).


Follow me:

Bug #2443

Redmine 3.4.2, Crash when opening "view all mentions"

Added by Carlos Rodrigues about 2 years ago. Updated 3 months ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
Due date:
% Done:

100%

Redmine version:
3.4.2
External issue:

Description

Redmine 3.4.2, Crash when opening “view all mentions”

Completed 500 Internal Server Error in 703ms (ActiveRecord: 93.8ms)

ActionView::Template::Error (undefined method `link_to_content_update' for #<#<Class:0x92faa50>:0x56f1e88>
Did you mean?  link_to_contact):
    34:   <% prev_params = params.dup %>
    35:   <% prev_params[:next_offset] = @prev_offset if @prev_offset %>
    36:   <% @prev_offset ||= 0 %>
    37:   <%= link_to_content_update("\xc2\xab " + l(:label_previous), prev_params.merge(:offset => @offset), :title => l(:label_previous)) if (@offset - @prev_offset) >= 50 %>
    38: </div>
    39: <div style="float: right;">
    40:   <%= link_to_content_update(l(:label_next) + " \xc2\xbb", params.merge(:offset => @next_offset), :title => l(:label_next)) if @next_offset %>
  plugins/wiking/app/views/mentions/index.html.erb:37:in `_plugins_wiking_app_views_mentions_index_html_erb__849827658_45532104'
  lib/redmine/sudo_mode.rb:63:in `sudo_mode'

Associated revisions

Revision 110 (diff)
Added by Andriy Lesyuk 3 months ago

Fixed new issue notification, fixed #2443

History

#1 Updated by Andriy Lesyuk about 2 years ago

  • Description updated (diff)
  • Status changed from New to Open
  • Assignee set to Andriy Lesyuk
  • Target version set to 1.1.1
  • Redmine version set to 3.4.2

Thanks for reporting.

#2 Updated by Luis Pereira over 1 year ago

The problem is probably

if (@offset - @prev_offset) >= 50 %>

Accounts with more than 50 mentions can’t access “view all mentions” because of that if.
Now or we remove it, or we change 50 to 500 for example.

#3 Updated by Andriy Lesyuk 3 months ago

  • Status changed from Open to Closed
  • % Done changed from 0 to 100

Applied in changeset r110.

Also available in: Atom PDF

Terms of use | Privacy policy