I'm looking for a part-time remote job.

Hire me


I'm the author of:

Mastering Redmine is a comprehensive guide with tips, tricks and best practices, and an easy-to-learn structure.

Check the book's project or

Buy the book

Social pages of the book:

By buying this book you also donate to Redmine (see this page).


Follow me:

Bug #2152

Do not replace characters in wiki links

Added by Xavier Calland about 7 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Category:
-
Target version:
Start date:
12 Feb 2013
Due date:
15 Oct 2013
% Done:

100%

Redmine version:
External issue:

Description

Links containing '–' '—' or apostrophes are false after characters replacment.

Links (href attribute) should not be changed by characters replacment.


Related issues

Related to WikiNG - Feature #2224: Option to disable glyphs? Incomplete 14 Sep 2013
Related to WikiNG - Feature #1917: Smart quotes Closed 19 Dec 2011 15 Oct 2013

Associated revisions

Revision 38 (diff)
Added by Andriy Lesyuk over 6 years ago

Fixed #2142 and #2152, started working on #2154 and #2158

Revision 61 (diff)
Added by Andriy Lesyuk over 6 years ago

Rfactored glyphs engine (#2152), added back smart quotes (#1917)

History

#1 Updated by Andriy Lesyuk almost 7 years ago

  • Status changed from New to Open
  • Assignee set to Andriy Lesyuk

#2 Updated by Andriy Lesyuk almost 7 years ago

  • Target version set to 0.0.4

#3 Updated by Andriy Lesyuk almost 7 years ago

  • Status changed from Open to In Progress
  • % Done changed from 0 to 20

The problem is, that at the moment of replacement it is not known, if it’s href or not... In any way parsing the syntax before replacement is, perhaps, too much. Not sure how to fix this issue... At the moment the only way seems to be:

  1. Require spaces before and after – and — (this way making sure, it’s not a link).
  2. Require users to use %27 instead of ' in URLs (any way apostrophes in URLs are problematic).

What do you think?

#4 Updated by Andriy Lesyuk almost 7 years ago

  • % Done changed from 20 to 70

#5 Updated by Andriy Lesyuk over 6 years ago

  • Status changed from In Progress to Incomplete
  • Target version deleted (0.0.4)

Ok, I believe the issue with dashes is not longer actual (it’s fixed)! Regarding apostrophes, I believe, I can’t do anything...

An apostrophe is a “reserved” character accordingly to RFC-3986. This means, that it can have a special meaning and not encoded in this case, or it should be encoded otherwise! Does apostrophe have a special meaning in your case?

Also it would be great to have samples of Wiki text with such links...

See also #2224.

#6 Updated by Andriy Lesyuk over 6 years ago

Got also another idea, which may be implemented in 1.0.0b or in some intermediate version.

#7 Updated by Andriy Lesyuk over 6 years ago

  • External issue set to #210

#8 Updated by Andriy Lesyuk over 6 years ago

  • External issue changed from #210 to #210, #645

#9 Updated by Andriy Lesyuk over 6 years ago

  • Target version set to 1.0.0b

#10 Updated by Andriy Lesyuk over 6 years ago

  • Due date set to 15 Oct 2013
  • Status changed from Incomplete to In Progress
  • % Done changed from 70 to 90

#11 Updated by Andriy Lesyuk over 6 years ago

  • Status changed from In Progress to Closed
  • % Done changed from 90 to 100

r61 should make it not be replaced in links. If it fails, please reopen the issue.

Also available in: Atom PDF

Terms of use | Privacy policy